Nuxt.js layer0 run succeeds deploy fails

With nuxt.js application I can locally run the application with layer0 but when I try to deploy, it starts to crash

2021-06-23T16:04:36Z - info - -----------------------
2021-06-23T16:04:36Z - info - InitializeBuild job started
2021-06-23T16:04:36Z - info - Running job 'initializeBuild' on xdn-build-lambda v3.16.0
2021-06-23T16:04:37Z - info - > Provisioning environment
2021-06-23T16:04:41Z - info - > Environment provisioned
2021-06-23T16:04:42Z - info - InitializeBuild job succeeded

2021-06-23T16:05:55Z - info - -----------------------
2021-06-23T16:05:55Z - info - DeployBuild job started
2021-06-23T16:05:55Z - info - Running job 'deployBuild' on xdn-build-lambda v3.16.0
2021-06-23T16:06:04Z - error - DeployBuild job failed [unexpected]: Error while invoking lambda "xdn-deploy-lambda": unexpected end of file

Interesting… we’ve seen this a few times now. It seems that the project zip gets corrupted during the upload process. If you try again does it work? Maybe it’s an intermittent issue. Can you share any details about the OS and version that you’re using?

no, I have tried many times and it’s the same error, we have tried with Windows and Mac and with the versions 3.6 and 3.16

I found the error, it was a problem in package.json; a package was in dependencies and I just move it to devDependencies

Just curious, what package was it that you needed to move to devDependencies?

sure, it was ‘@smiledirectclub/bulma-based-components’