Service worker failed to register and /__xdn__/cache-manifest.js responds with 534 undefined error on XDN

XDN version 2.33.5-next-1608319923-e478ce95.0

Our service worker and XDN devtools are functioning correctly in local development, but after deploying to XDN devtools reports “THE SERVICE WORKER IS NOT RESPONDING” and the service worker failed to register.

Errors reported in browser:

Uncaught DOMException: Failed to execute 'importScripts' on 'WorkerGlobalScope': The script at 'https://***' failed to load.
    at new e (https://***
    at Module.8VfV (https://***
    at n (https://***
    at https://***
    at https://***
e @ service-worker.js:1
8VfV @ service-worker.js:1
n @ service-worker.js:1
(anonymous) @ service-worker.js:1
(anonymous) @ service-worker.js:1
10:23:24.139 A bad HTTP response code (534) was received when fetching the script.
10:23:24.140 main-1123655fb1286f441b9e.js:1 SW registration failed:  TypeError: Failed to register a ServiceWorker for scope ('https://***') with script ('https://***'): ServiceWorker script evaluation failed

The route /__xdn__/cache-manifest.js responds with HTTP 534:

    "error": "Undefined error"

Sorry about the problem there. Could you upgrade to v2.34.2 and try again?

I tried and it’s the same result with the addition of x-xdn-version: 188 2.34.2 2020-12-22T18:48:54.525Z 269 header

This has been logged as XDN-7871

@jadkison Could you upgrade to version 2.35.1-next-1608731993-cd4a9f2d.0 and see if it fixes the issue for you?

That fixed the issue! Thanks

Thank you! We will release a patch ASAP.

We have released v2.35.1 which includes this fix.