Gatsby tutorial fails on first deploy

The gatsby tutorial seems to fail on first deploy.

It should be noted that this was the first time ever that i tried to deploy a site with xdn, not sure if that is relevant or not.

xdn deploy

� You are not logged in on

√ Let’s get you signed-in, your browser will open on » Continue
Authenticating user!
� You are now logged in as

You have uncommitted changes. No commit URL will be stored in

� Deploying to:

team=Private space

:hourglass: Initializing…

Deployment #1
Since this is the first deployment to the default environment, it will take longer than subsequent deployments.
done (23294ms)

�️ Building your app for deployment on the MOOVWEB XDN
success open and validate gatsby-configs - 0.005s
success load plugins - 0.092s
success onPreInit - 0.024s
success delete html and css files from previous builds - 0.005s
success initialize cache - 0.004s
success copy gatsby files - 0.094s
success onPreBootstrap - 0.019s
success createSchemaCustomization - 0.001s
success Checking for changed pages - 0.000s
success source and transform nodes - 0.035s
success building schema - 0.344s
info Total nodes: 18, SitePage nodes: 1 (use --verbose for breakdown)
success createPages - 0.001s
success Checking for changed pages - 0.000s
success createPagesStatefully - 0.072s
success Cleaning up stale page-data - 0.003s
success update schema - 0.021s
success onPreExtractQueries - 0.000s
success extract queries from components - 0.032s
success write out redirect data - 0.001s
success onPostBootstrap - 0.000s
info bootstrap finished - 4.996s
success run page queries - 0.009s - 3/3 326.39/s
error Failed to write out requires EPERM: operation not permitted, rename ‘D:\HUNGRYBEARSTUDIO\MOOVWEB\gatsby-site.cache\async-requires.js.1604752606419’ -> ‘D:\HUNGRYBEARSTUDIO\MOOVWEB\gatsby-site.cache\async-requires.js’

Error: EPERM: operation not permitted, rename ‘D:\HUNGRYBEARSTUDIO\MOOVWEB\gat sby-site.cache\async-requires.js.1604752606419’ -> ‘D:\HUNGRYBEARSTUDIO\MOOVW EB\gatsby-site.cache\async-requires.js’

not finished write out requires - 0.023s

Hi Rich!

(1) Are you using gatsby-starter-hello-world or a different site? If a different site, can you try with gatsby-starter-hello-world and see if you get the same error?

(2) Does a production gatsby build of this project work?


Hey Ishan,

(1) Im using the hello world that the tutorial suggests.
(2) By a production build, do you mean, does it build and then run locally? Or does the build deploy somewhere else and work?

— Update —

I ran gatsby dev which created a cache and public dirs, then tried xdn deploy again and it worked to deploy.

My guess would be something like whats happening here: Skip global xdn npm install