Nuxt3 integration is broken

Following the Nuxt3 integration guide and running npm run layer0:dev runs the sample project successfully.
Buf you wait for it to compile and load the homepage. There are 404 errors for all /_nuxt/ paths.

Example project: GitHub - tinhtm/layer0-nuxt3

Working example link:
GitHub: GitHub - rishi-raj-jain/nuxt3-layer0

Steps to install it:

Steps to run it:

  • 0 dev (or npm run 0:dev)
  • 0 build (or npm run 0:build)
  • 0 run -p (or npm run 0:prod)
  • 0 deploy (or npm run 0:deploy)

Spinned up a connector for you by following: Connectors | Layer0 Documentation.

  • In layer0/prod.js: I just load the node-server as generated by Nitro
  • In layer0/dev.js: I run npm run dev which invokes nuxt dev
  • In layer0/build.js: I build the Nuxt 3 project with npm run build which invokes nuxt build. Then I add the respective folders to work on serverless or static storage. Further, I create set of routes from the folder .output/public so that these are automatically cached with Layer0, and you can freely set the config of these public assets in routes.js

Overall at the time of writing, you can just clone this, and continue to develop like a Nuxt 3 app, all is handled to work with Layer0.

The background on this issue is that a change on the Nuxt side from nuxt3@latest to nuxt@3.0 is causing the Layer0 connector to use the Nuxt 2 connector instead of the Nuxt 3 connector. Layer0 developers are testing a fix and should have a pre-release available shortly.

Please refer to Nuxt 3 - Roadmap for the Nuxt 3 roadmap. As of the time of this writing, Nuxt 3 is still in a release candidate (RC) state and is not yet stable.

I’m getting the same error trying to implement layer0 in a nuxt app, anyone managed to make this work?


For now I believe you can get running with Edgio via:

cd nuxt3-app
edgio init --connector=@edgio/nuxt-nitro

More on migrating from Layer0 to Edgio CLI: Edgio Version 6 Migration Guide | Edgio Documentation